Updating Flash plugin on Debian Jessie

If you are a regular user of Firefox browser, Mozilla has a dedicated webpage to check your plugins’ version : Check the version for your installed plugins

If your Flash plugin is outdated, the best way to update it is to use the Debian package flashplugin-nonfree

Check your current version :

[root@localhost:~]#/usr/sbin/update-flashplugin-nonfree –status
Flash Player version installed on this system : 11.2.202.643
Flash Player version available on upstream site: 11.2.202.644
flash-mozilla.so – auto mode
link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
/usr/lib/flashplugin-nonfree/libflashplayer.so – priority 50
Current ‘best’ version is ‘/usr/lib/flashplugin-nonfree/libflashplayer.so’.

To update it :

[root@localhost:~]#/usr/sbin/update-flashplugin-nonfree –install

Check now your new version :

[root@localhost:~]#/usr/sbin/update-flashplugin-nonfree –status
Flash Player version installed on this system : 11.2.202.644
Flash Player version available on upstream site: 11.2.202.644
flash-mozilla.so – auto mode
link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
/usr/lib/flashplugin-nonfree/libflashplayer.so – priority 50
Current ‘best’ version is ‘/usr/lib/flashplugin-nonfree/libflashplayer.so’.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s