Lost connectivity to the device mpx.vmhba32:C0:T0:L0 backing the boot filesystem

usb_module_not_available_on_esxi_hp_hosts

This issue appeared on HP blade Proliant XL170r Gen9 running ESXi 6.0.0, 4192238.
Make sure that your blades have their firmwares updated to the latest version.
Have a look at iLO self-Test Results :

Before firmwares upgrade :
hpe_ilo_diagnostics_before_firmwares_upgrade

After firmwares upgrade :
hpe_ilo_diagnostics_after_firmwares_upgrade

How to list the CVEs fixed in a given rpm ?

A quick tip to retrieve the CVEs fixed in a given version of a rpm :


[fool@localhost:~]$ rpm -q --changelog openssl-libs-1.0.1e-51.el7_2.4.x86_64 | grep CVE-2014-3567
- fix CVE-2014-3567 - memory leak when handling session tickets

[fool@localhost:~]$ rpm -q --changelog openssl-libs-1.0.1e-51.el7_2.4.x86_64 | grep CVE-2014-8176
- fix CVE-2014-8176 - invalid free in DTLS buffering code

[fool@localhost:~]$ rpm -q --changelog openssl-libs-1.0.1e-51.el7_2.4.x86_64 | grep CVE-2015-0292
- fix CVE-2015-0292 - integer underflow in base64 decoder

Using the sed utility, all the CVEs fixed can be retrieved.
For the php rpm package :

[fool@localhost:~]$ rpm -q --changelog php |grep 'CVE-201[0-6]-[0-9]\{4\}' |sed -e '1s/^.*\(CVE-201[0-6]-[0-9]\{4\}\)/\1/' -e 's/^-.*\(CVE-201[0-6]-[0-9]\{4\}\)/\1/' -e 's/^\s*.*\(CVE-201[0-6]-[0-9]\{4\}\)/\1/' -e 's/, #[0-9]\{7\}//' |sed -e 's/)//g'

For the openssl rpm package :

[fool@localhost:~]$ rpm -q --changelog openssl |grep 'CVE-201[0-6]-[0-9]\{4\}' |sed -e '1s/^.*\(CVE-201[0-6]-[0-9]\{4\}\)/\1/' -e 's/^-.*\(CVE-201[0-6]-[0-9]\{4\}\)/\1/' -e 's/^\s*.*\(CVE-201[0-6]-[0-9]\{4\}\)/\1/' -e 's/, #[0-9]\{7\}//' |sed -e 's/)//g' |sed -e 's/(#.*$//g' -e 's/(.*//g' -e 's/\s.*$//g'